OK I am having odd problems with an applet I downloaded. I have used applets before and understand some of Java, but I do not understand this problem at all...IE gives me:
Code:
Error loading class: ViewTimer1
java.lang.NoClassDefFoundError
java.lang.ClassNotFoundException: ViewTimer1
	at com/ms/vm/loader/URLClassLoader.loadClass
	at com/ms/vm/loader/URLClassLoader.loadClass
	at com/ms/applet/AppletPanel.securedClassLoad
	at com/ms/applet/AppletPanel.processSentEvent
	at com/ms/applet/AppletPanel.processSentEvent
	at com/ms/applet/AppletPanel.run
	at java/lang/Thread.run
but Netscape runs it just fine. I tried downloading the latest Java plugins and selected to install them to both Netscape and IE, but nothing changed.
The other problem is that Netscape gives me the following message:
Code:
MalformedURLException:
java.net.MalformedURLException: no protocol: cgi-bin/timerinc.pl&delta=10
The "cgi-bin/timerinc.pl" is a PARAM passed to the script...I thought maybe I just had to use an absolute address with the http:// on it, but that didn't work either.

DETAILS:
I got an applet to track the time a user spends on a page--it uses a timer to update a count every 10 seconds, then, in stop(), it submits the data to a Perl script, which records the user's IP and time to a file.

I got the class file (it has no other dependencies--just the one file "ViewTimer1.class") and put it in a directory called "java". On my page I am using the following code:
Code:
<applet codebase="java" 
	code="ViewTimer1.class"
 	width=360 
	height=180>
	<param name="timerSource" value="cgi-bin/timerinc.pl">
	<param name="speed" value="10">
	Please enable Java
</applet>
Note that this applet does not actually display anything--so normally the height and width would be 0. I gave it some size just so I could make sure the applet was at least displaying...
As I said, Netscape loads the applet (but has a MalforedURLException in the stop() function--at least the stop function is executing though!). IE gives me a ClassNotFoundException.

You may view the page where I'm testing the applet here:
http://acamiddle.hypermart.net/NEW/test.html
There is another applet there which I was testing just to see if any applets worked...it's not working either (in IE, that is).
You may also want to download:
http://acamiddle.hypermart.net/NEW/j...ewTimer1.class
http://acamiddle.hypermart.net/NEW/java/ViewTimer1.java

I would appreciate any insight you can give me into correcting these issues! (Even if you just say "Hey, it works in IE for me" so that I would know my browser's screwed up...)
Thanks!

virtualoverride