Tomcat loads but jsp's don't work


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: Tomcat loads but jsp's don't work

  1. #1
    Join Date
    Mar 2003
    Posts
    1

    Question Tomcat loads but jsp's don't work

    Hi all,

    I'm brand new to all of this. I've installed jdk to my C drive, and after much trial and error, modified my autoexec.bat to set my environment variables for JAVA_HOME and CATALINA_HOME.

    In Tomcat, Startup.bat works, and the localhost:8080 page loads correctly in my browser.

    But when I click on the jsp examples, they don't work and report this in the "root cause" area of the error page:

    java.lang.NoClassDefFoundError: sun/tools/javac/Main

    ...followed by a long list of errors.

    Any ideas what's wrong?

    Thanks in advance,

    Fred

  2. #2
    Join Date
    Mar 2003
    Posts
    17
    Sun has a tools.jar that they ship out with the sdk download of Java (perhaps the JRE download too, not sure.)

    One of the classes in the jar is a Java class version of the command javac that allows you to compile source code from your own code.

    I am assuming the JSP or TomCat is attempting to do this, but you do not have the tools.jar in your class path so it cannot find the class.

    The tools.jar is usually located in the lib directory of your sdk installation. Hope this helps, haven't played with TomCats JSP's before so not absolutely sure if this will solve all your problems.
    Laziness is a virtue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center