I downloaded JMF 2.1.1 and tried to use the example
JPegImagesToMovie.

i am having problems with creating the datasink
====================
My input line is:
C:\???\???>java JpegImagesToMovie -w 256 -h 256 -f 1 -o file:c:\???\???\test.avi c:\???\???\1.jpeg c:\???\???\2.jpeg c:\???\???\3.jpeg c:\???\???\4.jpeg

the output is...
- create processor for the image datasource ...
Setting the track format to: JPEG
- create DataSink for: f:/a.mov
Cannot create the DataSink: javax.media.NoDataSinkException: Cannot find a DataSink for: com.sun.media.multiplexer.BasicMux$BasicMuxDataSource@3b1d04
Failed to create a DataSink for the given output MediaLocator: f:/a.mov



Also I have a problem when i tried to create avi files.
I changed...
====================
p.setContentDescriptor(new ContentDescriptor(FileTypeDescriptor.QUICKTIME));

TO

p.setContentDescriptor(new ContentDescriptor(FileTypeDescriptor.MSVIDEO));


====================
It processes ok(?), giving...

- create processor for the image datasource ...
Setting the track format to: RGB, 24-bit, Masks=3:2:1, PixelStride=-1, LineStrid
e=-1, Flipped
- create DataSink for: file:c:\???\???\test.avi
start processing...
- reading image file: C:\???\???\1.jpeg
- reading image file: C:\???\???\2.jpeg
- reading image file: C:\???\???\3.jpeg
- reading image file: C:\???\???\4.jpeg
Done reading all images.
...done processing.

It creates an avi file that cannot be opened in neither JMStudio nor Windows Media 9 (?).

what to do, what to do?
-Mick