Servlet + Tomcat Problems


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: Servlet + Tomcat Problems

  1. #1
    Join Date
    Nov 2003
    Posts
    1

    Unhappy Servlet + Tomcat Problems

    Recently, I`ve just installed Tomcat ver 4.1.29 with Apache Http Server ver 2.0.48. The weird problem is, I can run JSP in <tomcat home>/WebApps/root, but I cant run my Servlet in <tomcat home>/webapps/root/Web-INF/classes. But, if I put my Servlet in <tomcat home>/webapps/examples/WEB-INF/classes, it worked perfectly.

    Anybody knows the reason to this? Do I need to set any class path or something?

  2. #2
    Join Date
    Nov 2003
    Posts
    9
    I see that u mentioned using Apache httpd with tomcat. Does this mean you are using jk_mod? If that's the case, you also have to specify the servlet path in the...where was it again...hmm.. let me think here....

    Oh in httpd.conf in Apache conf folder with JKMount is you are doing it that way or...in workers property file......anyways there are many different ways of doing this depening on how you connected tomcat and apache together. If you supply with me with more info i migth be able to help you out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center