trying out the code in this interesting article:

has anyone successfully tried this?
my specs:
-eclipse 3.0,jboss1.4, jdk1.5, axis,wss4j

having problems with @ the following line:
SOAPEnvelope unsignedEnvelope = axisMessage.getSOAPEnvelope(); (line 92)

the eclipse editor is saying:
Type mismatch: cannot convert from SOAPEnvelopeAxisImpl to SOAPEnvelope

great, steps taken:
- changed library import from SOAPENvelope to SOAPEnvelopeAxisImpl....and changed a few in the code which were straight
SOAPEnvelopeAxisImpl unsignedEnvelope = axisMessage.getSOAPEnvelope(); (line 92)
- it ran in jboss, a different error: a snippet
Axis fault
faultString: Version Mismatch

org.apache.axis.AxisFault: VersionMismatch....
what could be the problem? hoping some pointers and I'll try it out

tx in advance