DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2006

    J2EE Client Provisioning problem

    Hi, I'm a newbie to servers and EE 5 in particular, so please forgive me if this problem seems trivial - but I've spent several days now to no avail, so you'll understand what that means in terms of frustration.

    I'm trying to deploy a J2ME package on the web, so have been following the Getting Started with the J2EE Client Provisioning tutorial (http://developers.sun.com/techtopics...art/index.html) listed in the MIDP articles section. Unlike the tutorial which is a bit old (written for j2sdkee1.3.1), I've downloaded EE 5. When I come to build and deploy the application, ant/asant falls over, and gives the following error:

    [java] java.lang.NoClassDefFoundError: com/sun/enterprise/tools/packager/Main
    [java] Exception in thread "main"

    Now, as far as I can ascertain, there are a couple of likely causes for this problem. My first instinct tells me that I don't have the Environment Variables set correctly. Here are my PATH and CLASSPATH settings:

    C:\Program Files\Java\jdk1.5.0_06\bin;C:\Sun\AppServer\bin;C:\apache-ant-1.6.5-bin\apache-ant-1.6.5\bin


    There may well be entries there that are superfluous: in desparation I've been trying all sorts of different ones. Is anything missing though??

    Secondly, perhaps since the application is a bit old, the build.xml might need changing. Here is the segment it falls over on:

    <!-- First create the portable .ear file -->
    <java classname="com.sun.enterprise.tools.packager.Main"

    I have SCOURED the net and can find no solution. With a bit more experience I might be able to solve it myself, but am at a loss. If anyone can help...I would be so grateful. If there is a better place to submit this sort of a query, pls let me know.


  2. #2
    Join Date
    Apr 2006
    Still no solution here, but I'll try to report on all the steps/developments (no matter how minor) I've made:

    Having tried all manner of CLASSPATH and PATH formatting and entries, I started to examine the Build.xml that comes with the application in more detail. In the opening lines appears the following:

    <property name="j2ee.l10n" value="${j2ee.home}/lib/locale" />, the name of which appears in the XML segment from my initial thread. The destination this property is specifying does not exist on my machine, and I cannot find any such file anywhere. I guess this is a difference between EE 5 and J2EE1.3. If that's the case, how should I alter this property accordingly, for use with EE 5?

    Another potential discrepancy I noticed occurs when I run ant -debug. It details that it is setting project property j2ee.jar -> C:\Sun\AppServer/lib/j2ee.jar. Might this \ / mix-up be causing a problem?

    I'll keep thinking.

    Thanks again for anyone devoting time to this problem. If I can supply any more info/code that would be useful do let me know.

Similar Threads

  1. Replies: 3
    Last Post: 03-21-2007, 03:28 PM
  2. Reliability Problem
    By elise in forum .NET
    Replies: 0
    Last Post: 10-30-2002, 04:39 AM
  3. Replies: 60
    Last Post: 09-13-2002, 05:41 PM
  4. COM+ Problem Pls Help
    By Kevin Moore in forum .NET
    Replies: 3
    Last Post: 06-04-2002, 06:44 PM
  5. Reposition MDI Client window?
    By Noel Gallagher in forum VB Classic
    Replies: 4
    Last Post: 04-05-2000, 07:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center
Latest Articles
Questions? Contact us.
Web Development
Latest Tips
Open Source

   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.