Hi all, I'm trying my first complicated JAVA program and it can't find certain packages. I have set my classpath to the directory they're in, I think, but that all depends on whether packages are what I think they are. Am I correct in assuming that packages are directories? I wouldn't see, for example, a file with XName.pkg, right? I have to direct the compiler/interpreter to com/sun/star/uno, and I've set the classpath to /opt/openoffice.org2.0_sdk/idl/com/sun/star/. Really, I'm sure- when I use echo $CLASSPATH, that's what I get, and it's set in my .bashrc. However, when I try to compile a java program that looks for the package com.sun.star.uno.XComponentContext, I get "package com.sun.star.uno does not exist" followed by the offending line: "import com.sun.star.uno.XComponentContext". I tried specifying import opt.openoffice... etc. for the full dir name, but that didn't work, not to mention the fact that openoffice.org2.0_sdk probably wouldn't work so well, given that the . in that filename isn't for another directory. But that's not the problem, I don't think.
So if anyone can enlighten me as to how to get my program to find these classes I would be very, VERY grateful. Also, as I've checked and I know there isn't a UnoRuntime package ON MY WHOLE COMPUTER, if anyone has done some OpenOffice work and knows where that's found, I'd appreciate that, too, but for right now I'd settle for just being able to find packages.

Thank you very much for your time, and for goodness sake, help me! I've been programming for seven years, I've worked with Java for one, and this is just embarassing! Thanks!