.NET framework 1.1 and 2.0 compatibility.


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 3 of 3

Thread: .NET framework 1.1 and 2.0 compatibility.

  1. #1
    Join Date
    Oct 2006
    Posts
    1

    .NET framework 1.1 and 2.0 compatibility.

    Am interested to know what changes will i have to do so that my application developed in framwork 1.1 will run smoothly with framework 2.0.

    To best of my knowledge it will run in framework 2.0 w/o any modifications. Let me know if am wrong and what changes will i have to make to run it in framework 2.0.

    Also is it possible that if i developed an appln in framework 2.0 can I run it using framework 1.1 provided new features introduced in 2.0 are not used.

    Will framework 2.0 be installed on my 1.0 GHz / 256 Ram /Win 2000 m/c where framework 1.1 is already been installed or i would be very happy to know the hardware requirements for both frameworks. (Not expecting link to MSDN)

    thanks in advance.

  2. #2
    Join Date
    Dec 2003
    Posts
    2,750
    It isn't clear from your post whether you are planning on compiling your application (using VS 2005) for the 2.0 Framework or whether you are just going to run it as is (compiled for 1.1).

    While you can configure your 1.1 app to run under the 2.0 Framework, by default it will run under 1.1. Also, there is no way to know whether your app will have any compatibility issues under 2.0 until it is tested.

    The hardware requirements would be different depending upon whether the machine is a desktop or server. The more RAM the better of course and I would consider 256 a minimum. You're probably OK with 1.0 gHz but once again, the faster the better.
    Paul
    ~~~~
    Microsoft MVP (Visual Basic)

  3. #3
    Join Date
    Jun 2004
    Posts
    93
    Lets assume VB.Net
    VB2003 apps require DotNetFW 1.1
    VB2005 apps require DotNetFW 2.0

    VB2003 App: DotNetFW is backward compatible. If the user only has DotNetFW 2.0 , you will be OK (backward compatibility). If the user has DotNetFW 1.1 you will be OK. If the user has DotNetFW 1.1 and 2.0, you are OK.

    VB2005 app: DotNetFW is not forward compatible, regardless of features used.
    If you only have DotNetFW 1.1, your app will not run. You need DotNetFW 2.0.

    Now, assuming you want to upgrade your application from VB2003 to VB2005, you should have few, in any, problem. The project should convert and any issues will be noted in the task list.

Similar Threads

  1. How can I install .NET framework 2.0 ?
    By Matrix.net in forum .NET
    Replies: 5
    Last Post: 10-26-2006, 09:24 AM
  2. Replies: 2
    Last Post: 09-19-2006, 07:33 PM
  3. Replies: 0
    Last Post: 06-26-2006, 03:07 AM
  4. How to configure .NET VS 2003 to use .net 2.0
    By jennywongus in forum .NET
    Replies: 2
    Last Post: 02-21-2006, 10:33 PM
  5. ANN: Release of DeKlarit 2.0 for Microsoft Visual Studio .NET
    By Maria Jose Serres in forum dotnet.announcements
    Replies: 0
    Last Post: 02-19-2003, 02:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center