When I open or try to create new DataSets (.xsd), Visual Studio opens them using the XML editor instead of the default DataSet Editor. When I try the right-click -> Open With option, DataSet Editor is not one of the available options in the list.

The default one is now set to the XML editor. I was able to create DataSets using the DataSet editor before, until this happened. How do I make Data sets open with the DataSet Editor/Designer again?

I have already tried repairing Visual Studio thru Control Panel -> Add/Remove but the problem still persists