Hello,
I have this simple script i found a tutorial for online, it basically mimics google suggest except it pulls keywords from my database for search my website.

The script and search box worked fine on my windows server but now that I pushed over to my FC6 server the AJAX script doesnt seem to work ne more...

PHP Code:
var obj;
function 
GetDataViaAJAX(){
    if (
window.XMLHttpRequest) {
        
// Not IE
        
obj = new XMLHttpRequest();
    } else if (
window.ActiveXObject) {
        try{
            
obj = new ActiveXObject("Msxml2.XMLHTTP");
        }
        catch(
e){
            try{
                
obj = new ActiveXObject("Microsoft.XMLHTTP");                        
            }
            catch(
e1){
                
obj null;
            }
        }
    }

    if(
obj!= null){
        if(
document.getElementById("query").value.length 1){
            
document.getElementById('Label2').style.display='block';
            
obj.onreadystatechange ProcessResponse;
            var 
aURL "http://192.168.111.45/NewWeb/ajaxSearch.php?SearchTerm=" document.getElementById("query").value;
            
//alert(aURL);
            
obj.open("GET"aURL,  true);
            
obj.send(null);
        }
        if(
document.getElementById("query").value.length 1) {
            
document.getElementById('Label2').style.display='none';
            }
    } 
    return 
false;
}

function 
ProcessResponse(){
    if(
obj.readyState == 4){
        if(
obj.status == 200){
            var 
retval=obj.responseText;
            
document.getElementById("Label2").innerHTML retval;
        }
        else{
            
//alert(obj.status);
        
}
    }

Its not the best script, like I said I found a tutorial online... but does anyone know why it wouldnt work all of the sudden on the new server? Please let me know and thank you.