VB6 connection to Progress Database


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 7 of 7

Thread: VB6 connection to Progress Database

  1. #1
    Join Date
    Aug 2007
    Posts
    3

    VB6 connection to Progress Database

    For the last 5 years we have been using a Progress 9.1C database and have been able to successfully connect to the database to pull information via a VB6 application. Recently, our database was upgraded to Progress 10.1A and our application no longer works. We have installed the Progress OpenEdge 10.1A ODBC drivers on the machines, but now receive an error message when executing the application.

    The error message is
    "Run-time Error '-2147467259 (80004005)':
    [DataDirect][ODBC OPENEDGE driver][OPENEDGE]Syntax Error at or about %s(statement excerpt). (10713)"

    I have tried everything that is listed on Progress' website, but to no avail.

    I have traced the error message to a SQL statement in VB that has a Progress table name containing a hypen in it. Other queries to the database run just fine. I can run the same query using Microsoft Access 2003/2007 without issue.

    Does anyone have any idea what I can do to fix this issue?

  2. #2
    Join Date
    Apr 2007
    Location
    Sterling Heights, Michigan
    Posts
    8,666
    Welcome to DevX

    Do you have a support contract with them? Have you tried their support line?
    I don't answer coding questions via PM or Email. Please post a thread in the appropriate forum section.
    Please use [Code]your code goes in here[/Code] tags when posting code.
    Before posting your question, did you look here?
    Got a question on Linux? Visit our Linux sister site.
    Modifications Required For VB6 Apps To Work On Vista

  3. #3
    Join Date
    Aug 2007
    Posts
    3
    We do not have support with them...I am checking out their forums as well.

  4. #4
    Join Date
    Apr 2007
    Location
    Sterling Heights, Michigan
    Posts
    8,666
    Well, you are a customer. That should account for something.

    I just don't know how many folks on this site have any experience with Progress databases (I sure don't)
    I don't answer coding questions via PM or Email. Please post a thread in the appropriate forum section.
    Please use [Code]your code goes in here[/Code] tags when posting code.
    Before posting your question, did you look here?
    Got a question on Linux? Visit our Linux sister site.
    Modifications Required For VB6 Apps To Work On Vista

  5. #5
    Join Date
    Dec 2006
    Posts
    7

    Basic Troubleshooting 101

    Basic db troubleshooting 101.

    You have a db.
    You have a connector
    You have an application.

    One point in the chain is failing.

    Have you tried connecting to the db with windows odbc (control panel->administritive tools->data sources(ODBC)) ? Is your application using the newer datasource driver?

    Setting up a link via another application like access to connect to the db?

    If the link works, then check the application.

  6. #6
    Join Date
    Aug 2007
    Posts
    3
    I have tried everything that you have said and have the following results.

    Using new ODBC driver - yes
    Connection to database - successful
    Tried application in debug mode - yes

    The application bombs when running a SQL statement that is requesting data from a table name that has a "-" (hyphen) in it. If I comment out the code and rerun the program it works just fine.

    My dilemna is this: Run the same query from Microsoft Access and it returns results...run from Visual Basic and the code bombs. They are both referencing the same ODBC driver.

    Any thoughts on why this would be?

  7. #7
    Join Date
    Dec 2006
    Posts
    7
    show the sql

Similar Threads

  1. unable to read data from database
    By dppalepu in forum Java
    Replies: 2
    Last Post: 07-27-2006, 04:15 AM
  2. Database Maintenance from VB6
    By Gary Bouchard in forum Database
    Replies: 0
    Last Post: 05-11-2006, 01:31 PM
  3. need help setting up a connection in VB6!!!
    By spuddlet in forum VB Classic
    Replies: 1
    Last Post: 09-30-2005, 01:32 PM
  4. WebParts and database connection
    By geoyar in forum ASP.NET
    Replies: 0
    Last Post: 09-01-2005, 03:10 PM
  5. Facing Problem with Database connection
    By Venkat in forum ASP.NET
    Replies: 0
    Last Post: 07-04-2001, 01:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center