Hi all,

I have taken the latest version of commons-fileupload.jar and tried to upload the file.

I am reading the following way.

DiskFileItemFactory factory = new DiskFileItemFactory();

// Set factory constraints
factory.setRepository(new File(""));

// Create a new file upload handler
ServletFileUpload upload = new ServletFileUpload(factory);

// Set overall request size constraint

List items = upload.parseRequest(a_Req);

Test Case 1.

I am trying to upload a zip file which has 3-4 files without any parent directory.

Then i get the correct file path and file names in the List items

Test Case 2:

When I try to upload a zip file which has 3-4 files within a particular directory structure, i am not getting the files names. Instead, i am getting the same zip file name.

Is it that the ServletFileUpload doesn't support these type of zip files or is it that i am missing something?

I tried to search @ http://commons.apache.org/fileupload/.

But coudn't get much info.

Can somebody pls help me out.

Thanks in advance.
Tanuja Goturi