configurong website 'http://localhost/website' to asp.net 2.0 failed


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 8 of 8

Thread: configurong website 'http://localhost/website' to asp.net 2.0 failed

  1. #1
    Join Date
    Feb 2008
    Posts
    3

    configurong website 'http://localhost/website' to asp.net 2.0 failed

    When creating a new web-site and setting the location to "HTTP", i get the following error:-

    You may need to manually configure this site for asp.net 2.0 in order for your site to run properly.

    Can anybody help me out with this??

    After selecting the proper asp.net version from iis, WHEN I RUN THE WEB-SITE BY PRESSING F5, again I get an error :

    Unable to start debugging on web server. The server does not support debugging of ASP.NET or ATL Server applications.

    Also, if i run the website without debugging(Ctrl+F5), the browser gives the error:

    XML Parsing Error: not well-formed
    Location: http://localhost/WebSite12/Default.aspx
    Line Number 1, Column 2:<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="_Default" %>

    Also, there is some error related to the METABASE file...

    Please anyone help me out with this.

  2. #2
    Join Date
    Apr 2007
    Location
    Sterling Heights, Michigan
    Posts
    8,663
    Quote Originally Posted by sghulyani
    You may need to manually configure this site for asp.net 2.0 in order for your site to run properly.
    Try this:

    1) from cmd window, type inetmgr
    2) Expand your Internet Information Services nodes -> <Machine Name>
    3) click on "Web Service Extension" node
    4) in the right handside window, select the current ASP.NET build installed on the machine (e.g. ASP.Net V2.0.50215)
    5) click Allow button
    Last edited by Hack; 02-27-2008 at 07:50 AM.
    I don't answer coding questions via PM or Email. Please post a thread in the appropriate forum section.
    Please use [Code]your code goes in here[/Code] tags when posting code.
    Before posting your question, did you look here?
    Got a question on Linux? Visit our Linux sister site.
    Modifications Required For VB6 Apps To Work On Vista

  3. #3
    Join Date
    Feb 2008
    Posts
    3
    Hey Hack, there is no such "Web Service Extension node" in the IIS.

    If possible, do put the screenshot in your reply.
    I would be very thankful to you...


    I even tried re-installing IIS, but to no help.

    Will re-installing VS 2005 do the trick?

  4. #4
    Join Date
    Apr 2007
    Location
    Sterling Heights, Michigan
    Posts
    8,663
    Are you an admin of the box? If yes, you can try running this command
    >aspnet_regiis -i -enable
    I don't answer coding questions via PM or Email. Please post a thread in the appropriate forum section.
    Please use [Code]your code goes in here[/Code] tags when posting code.
    Before posting your question, did you look here?
    Got a question on Linux? Visit our Linux sister site.
    Modifications Required For VB6 Apps To Work On Vista

  5. #5
    Join Date
    Feb 2008
    Posts
    3
    hey, even this command is not working...
    It gives an error that windows cannot find aspnet_regiis. Make sure you typed the name correctly....

  6. #6
    Join Date
    Feb 2010
    Posts
    2
    Sorry for resurrecting an old thread but I had a similar problem and this post helped me figure it out...sort of anyway. Here is how I resolved this issue.

    I was missing the "ASP.NET v2.0.50215" entry in my Web Service Extensions and getting the same 404 error when trying to run .net 2.0 stuff on IIS 6.

    The command "aspnet_regiis -i -enable" will put this entry into the web service extensions, BUT you have to run it from a command prompt, from inside the .net folder itself. So do this:

    • Click Start > Run > Type "CMD" and hit Enter.
    • At the command Prompt, type "CD C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727"
    • Type "aspnet_regiis -i -enable" and hit Enter.
      NOTE: In my environment, Windows was my Windows install folder, yours may be WinNT or something other. Also, don't type in the " characters, but everything in between them.

    After the above command finished, I had the proper entry in my Web Service Extensions and it was set to enable. ASPX pages are now working.

    Hope this helps someone else out.

    -Todd

  7. #7
    Join Date
    Sep 2011
    Posts
    1
    hi
    I had the exact problem and did what you have written here but I get following error :

    operation failed 0x8007000B
    An attempt was made to load a program with an incorrect format.


    what should I do ? ;(

  8. #8
    Join Date
    Feb 2010
    Posts
    2
    Quote Originally Posted by cactusgroup View Post
    hi
    I had the exact problem and did what you have written here but I get following error :

    operation failed 0x8007000B
    An attempt was made to load a program with an incorrect format.


    what should I do ? ;(
    Could it be a 64 bit server vs 32 bit app problem? Check this page out.
    http://stackoverflow.com/questions/2...net-regiis-exe

Similar Threads

  1. QUERY: Mixing ASP.NET 1.1 & 2.0 pages in same website
    By dhruba.bandopad in forum ASP.NET
    Replies: 3
    Last Post: 10-18-2006, 04:32 PM
  2. Cannot run ASP.NET 2005 website on Windows XP
    By Magdalene in forum ASP.NET
    Replies: 2
    Last Post: 04-07-2006, 10:17 PM
  3. Replies: 7
    Last Post: 03-15-2006, 11:43 PM
  4. Acessing a COM object in ASP.Net 2.0
    By robertmazzo in forum ASP.NET
    Replies: 0
    Last Post: 12-15-2005, 12:16 PM
  5. Replies: 0
    Last Post: 10-06-2005, 11:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center