I'll keep it short. I need help giving a particular website (http://updates.cubase.org/) FullTrust on my PC. I've tried 14 different variations on caspol.exe commands, and none work. My app still runs with LowTrust. What command do I need to execute to grant Full Trust to that domain?

Below are my original posts to the MSDN forums, but no one has replied there yet, so I'm hitting up other forums too

---POST 1
"CAS is tough stuff, and honestly seems incredibly ridiculous. Too bad there aren't any true work arounds. I need some help from the smart people here to get an app running when downloaded off a website. This app requires the ability to modify a file locally on the PC, so programming it as "low trust" isn't a possibility. It's located on a website, we'll call it my.domain.com (it's not a publically accessible site -- only for clients of my company). Right now, it throws the usual Security.Permissions error when ran off the website. What are my options?

I can do the RequestMinimum, but that doesn't seem to work on anything I've tried. From what I understand, it's not actually "requesting" permission, it just checking to see if it has it. My next option is to grant FullTrust to my.domain.com. How do I do this?

I've ran the following on my PC "caspol.exe -ag 1.3 -site my.domain.com FullTrust". But I still can't run anything off that site. It does show up when I run "caspol.exe -lg".

What do I do next?"

---POST 2
"OK, I'm incredibly frustrated now. I don't mind having to set a CAS policy on all workstations that will run my apps; that's fine. But how do I do it so that they can run from a particular website?

I have tried about 14 different commands now, and they all produce nothing. Here's a copy of my caspol -lg list:
1. All code: Nothing
1.1. Zone - MyComputer: FullTrust
1.1.1. StrongName - 00240000048000009400000006020000002400005253413100040
0000100010007D1FA57C4AED9F0A32E84AA0FAEFD0DE9E8FD6AEC8F87FB03766C834C99921EB23BE
79AD9D5DCC1DD9AD236132102900B723CF980957FC4E177108FC607774F29E8320E92EA05ECE4E82
1C0A5EFE8F1645C4C0C93C1AB99285D622CAA652C1DFAD63D745D6F2DE5F17E5EAF0FC4963D261C8
A12436518206DC093344D5AD293: FullTrust
1.1.2. StrongName - 00000000000000000400000000000000: FullTrust
1.2. Zone - Intranet: LocalIntranet
1.2.1. All code: Same site Web
1.2.2. All code: Same directory FileIO - 'Read, PathDiscovery'
1.3. Zone - Internet: Internet
1.3.1. All code: Same site Web
1.3.2. Site - updates.cubase.org: FullTrust
1.3.3. Url - updates.cubase.org: FullTrust
1.3.4. Url - http://updates.cubase.org/*: FullTrust
1.4. Zone - Untrusted: Nothing
1.5. Zone - Trusted: Internet
1.5.1. All code: Same site Web
1.6. Site - updates.cubase.org: FullTrust
1.7. Site - updates.cubase.org: FullTrust (LevelFinal)
1.8. Url - http://updates.cubase.org/*: FullTrust

As you can see, the URL is supposed to be http://updates.cubase.org/ and anything ran from there should be granted FullTrust. What do I need to do to get that site to have FullTrust on my workstation?"