WCF/MSMQ problem


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 6 of 6

Thread: WCF/MSMQ problem

  1. #1
    Join Date
    Oct 2008
    Posts
    20

    WCF/MSMQ problem

    I've created a prototype application which uses WCF and MSMQ to send simple "hello world" messages from a client app to a server app. I was able to get it successfully working on my machine.

    However, being a client/server technology, I need to get this prototype working across a network.

    So, I got a second PC, installed MSMQ on it and my client application. When I run the client app on this second PC, it does not work correctly. I don't get any run-time exceptions, however, the messages are not received on my server. If I go into my client PC's Computer Management console, I can see the messages in its outgoing queue. So, it appears that the problem is that my client app is not connecting to my server app.

    Both machines are on the same domain and can see each other in Windows Explorer. I'm able to copy files back and forth from both PCs. If I execute MessageQueue.GetPrivateQueuesByMachine() on my client PC, I can see my server's queues. I should note that my server's queue is private.

    I'm using Visual Studio 2008, .NET 3.5. My server machine is running Windows 7. My client PC is running Windows Server 2003 R2. My binding is netMsmqBinding.

    To create my prototype, I am using Michele Bustamante's QueuedServices example from chapter 6 of her "Learning WCF" book. You can download her example here: http://www.thatindigogirl.com/downlo...gWCFVS2008.zip

    My client side's app config is at the end of this post.

    I'm not sure what's wrong or even where to begin debugging this issue.

    Code:
    <?xml version="1.0" encoding="utf-8" ?>
    
    <configuration>
    
     <system.serviceModel>      
    
      <bindings>
    
       <netMsmqBinding>
    
        <binding name="netMsmq" >
    
         <security mode="None" />
    
        </binding>
    
       </netMsmqBinding>
    
      </bindings>
    
      <client>
    
       <endpoint address="net.msmq://MyComputerName/private/MessagingServiceQueue"
    
        binding="netMsmqBinding" bindingConfiguration="netMsmq"
    
        contract="WinClient.localhost.IMessagingService" name="netMsmq" />
    
      </client>
    
     </system.serviceModel>
    
    </configuration>
    Last edited by I-DOTNET; 03-08-2010 at 04:43 PM.

  2. #2
    Join Date
    May 2004
    Location
    Duluth MN
    Posts
    353
    I suspect it's you queue address reference. Review the public/private queue info in this article:

    http://www.devx.com/dotnet/Article/27560

    ...joe

  3. #3
    Join Date
    Oct 2008
    Posts
    20
    Thanks, but I've already read through that article a few times already.

    If I attempt to bypass WCF and send the message to MSMQ directly...

    Code:
    MessageQueue rmQ = new MessageQueue("FormatName:DIRECT=OS:MyComputerName\\private$\\messagingservicequeue");
    rmQ.Send("Hello world");
    ...I get the same behavior as before. The message is stuck in the client PC's outgoing queue.

  4. #4
    Join Date
    May 2004
    Location
    Duluth MN
    Posts
    353
    Sorry all my experience with MSMQ has been passing messages locally or to MSMQ servers setup by third parties. Since the messages are getting posted to your local queue, but not getting picked up by the remote, I would guess something about your receiving queue/server is not configured properly. Not very helpful, I know

    ...joe

  5. #5
    Join Date
    Oct 2008
    Posts
    20
    Here's something interesting that I discovered. I decided to switch my client/server PCs so that the host was running on my Win2003 machine and the client was running on my Win7 machine. It worked! I was able to receive messages across the network. So it's something about Windows 7 or my computer that's causing the problem. But what could it be?

  6. #6
    Join Date
    May 2004
    Location
    Duluth MN
    Posts
    353
    You might be better off posting to the MSMQ.Programming Forum. They may be better prepared to solve your problem.

    ...joe

Similar Threads

  1. Memory problem with Borland C3.1
    By AZ1699 in forum C++
    Replies: 11
    Last Post: 11-16-2007, 01:23 PM
  2. App Problem with MS Office ...
    By Shannon in forum VB Classic
    Replies: 7
    Last Post: 06-24-2007, 09:47 PM
  3. Replies: 0
    Last Post: 12-13-2001, 01:06 PM
  4. Arabic problem view
    By Ayman in forum VB Classic
    Replies: 0
    Last Post: 04-03-2000, 02:08 AM
  5. Problem with CryptoAPI and JCE
    By Jason Bock in forum VB Classic
    Replies: 0
    Last Post: 03-21-2000, 07:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center