WL;JAAS;BEA-101020;No Configuration was registered that can handle the configuration


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: WL;JAAS;BEA-101020;No Configuration was registered that can handle the configuration

  1. #1
    Join Date
    Sep 2009
    Posts
    1

    Red face WL;JAAS;BEA-101020;No Configuration was registered that can handle the configuration

    Hi,

    A) I am trying to run JAAS on Weblogic. We have got our own login module developed based on JAAS specification.

    I have created jas.config which is as follows:
    abcjaas {
    <pkg>.DBLoginModule required
    };

    which I have included in the system properties as
    set JAVA_OPTIONS=%JAVA_OPTIONS% -Djava.security.auth.login.config=D:\BeaWL\jaas.config

    B) I had also tried setting this
    set JAVA_OPTIONS=%JAVA_OPTIONS% -Dlogin.configuration.provider=com.bea.common.security.jdkutils.JAASConfiguration. This I have also tried configuring in the java.security file in the JDK folder.

    While in Java code, it precisly throws error here on this statement:


    loginContext = new LoginContext("abcjaas", callHandler);


    But for all the above trials, it gives the same error as follows:

    C)
    Inside : Authenticator ::authenticateUser()....
    <Sep 10, 2009 2:32:49 PM IST> <Error> <HTTP> <BEA-101020> <[weblogic.servlet.internal.WebAppServletContext@609547 - appName: CommercialLines_EAR', name: 'App', context-path: '/App', spec-version: '2.5'] Servlet failed with Exception
    java.lang.IllegalArgumentException: No Configuration was registered that can handle the configuration named abcjaas
    at com.bea.common.security.jdkutils.JAASConfiguration.getAppConfigurationEntry(JAASConfigurat ion.java:124)
    at javax.security.auth.login.LoginContext.init(LoginContext.java:243)
    at javax.security.auth.login.LoginContext.<init>(LoginContext.java:403)
    at <pkg>.Authenticator.authenticateUser(Authenticator.java:38)
    at <pkg>.LoginFilter.doFilter(LoginFilter.java:40)
    Truncated. see log file for complete stacktrace
    >


    D) Kindly help, the Weblogic 10.3.0.0 running on JDK1.6 -Sun provided. I am not using the JDK1.6 in WL10.3 or its Jrockit1.6.

    Please let me know the resolution.


    Cheers,
    -Vishal Kumar

  2. #2
    Join Date
    Sep 2011
    Posts
    1

    Solution?

    Did you ever get a solution to this problem?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center