SQL Server Agent wont auto start


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 3 of 3

Thread: SQL Server Agent wont auto start

  1. #1
    David Hay Guest

    SQL Server Agent wont auto start

    I have a problem with SQL Server Agent not starting up automatically. After
    booting the server it appears to start, but after a couple of minutes NT
    reports that one or more services failed to start and SQL Server Agent has
    stopped. At this point I can start SQL Server Agent manually without any
    problems. The NT Event Log has the following message:

    "SQLServerAgent could not be started (reason: Unable to connect to server;
    SQLServerAgent cannot start)."

    I can only find one atricle in the Knowledgebase related to this error
    message(Q237604), which indicates the problem is that "the
    BUILTIN\Administrators login does not have access to SQL Server or the
    BUILTIN\Administrators login has been removed from SQL Server. This is not
    the case. Also the knowledgebase article says that SQL Server Agent will
    not start manually either, but it does in my case.

    Other information: SQL7SP2, NT4SP6, starting the SQL Server and SQL Server
    Agent services using the system account.

    Any ideas?

    Thanks
    David





  2. #2
    Blade Guest

    Re: SQL Server Agent wont auto start


    Reinstall service pack 4 for SQL Server.



    "David Hay" <david.hay@aspect.com.au> wrote:
    >I have a problem with SQL Server Agent not starting up automatically. After
    >booting the server it appears to start, but after a couple of minutes NT
    >reports that one or more services failed to start and SQL Server Agent has
    >stopped. At this point I can start SQL Server Agent manually without any
    >problems. The NT Event Log has the following message:
    >
    >"SQLServerAgent could not be started (reason: Unable to connect to server;
    >SQLServerAgent cannot start)."
    >
    >I can only find one atricle in the Knowledgebase related to this error
    >message(Q237604), which indicates the problem is that "the
    >BUILTIN\Administrators login does not have access to SQL Server or the
    >BUILTIN\Administrators login has been removed from SQL Server. This is

    not
    >the case. Also the knowledgebase article says that SQL Server Agent will
    >not start manually either, but it does in my case.
    >
    >Other information: SQL7SP2, NT4SP6, starting the SQL Server and SQL Server
    >Agent services using the system account.
    >
    >Any ideas?
    >
    >Thanks
    >David
    >
    >
    >
    >



  3. #3
    David Hay Guest

    Re: SQL Server Agent wont auto start

    Reinstall SP4? We are using SP2, and I thought they were only up to SP3?
    Do you mean reinstall SP2?

    Blade <boolean@somewhere.com> wrote in message
    news:3ac8edf9$1@news.devx.com...
    >
    > Reinstall service pack 4 for SQL Server.
    >
    >
    >
    > "David Hay" <david.hay@aspect.com.au> wrote:
    > >I have a problem with SQL Server Agent not starting up automatically.

    After
    > >booting the server it appears to start, but after a couple of minutes NT
    > >reports that one or more services failed to start and SQL Server Agent

    has
    > >stopped. At this point I can start SQL Server Agent manually without any
    > >problems. The NT Event Log has the following message:
    > >
    > >"SQLServerAgent could not be started (reason: Unable to connect to

    server;
    > >SQLServerAgent cannot start)."
    > >
    > >I can only find one atricle in the Knowledgebase related to this error
    > >message(Q237604), which indicates the problem is that "the
    > >BUILTIN\Administrators login does not have access to SQL Server or the
    > >BUILTIN\Administrators login has been removed from SQL Server. This is

    > not
    > >the case. Also the knowledgebase article says that SQL Server Agent will
    > >not start manually either, but it does in my case.
    > >
    > >Other information: SQL7SP2, NT4SP6, starting the SQL Server and SQL

    Server
    > >Agent services using the system account.
    > >
    > >Any ideas?
    > >
    > >Thanks
    > >David
    > >
    > >
    > >
    > >

    >




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center