LDAP referral on Exchange 5.5


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: LDAP referral on Exchange 5.5

  1. #1
    Brad Perkins Guest

    LDAP referral on Exchange 5.5


    Hello,

    Anybody been succesful in setting up LDAP referrals on Exchange 5.5? I've
    got a Netscape Directory Server (LDAP server) that I've populated with some
    test users. I have configured the Exchange 5.5 LDAP referral to point to
    this Netscape server. When I use my LDAP client to search for name in Exchange
    directory that only exists on the Netscape Server, Exchange never comes back
    with any results. It always says there is no match.

    Is there a trick to this?

    Thanks,
    Brad
    Share on Google+

  2. #2
    Brad Perkins Guest

    Re: LDAP referral on Exchange 5.5


    This is sort of an update, still haven't got it working on exchange server
    though...

    I downloaded and setup a Lotus Domino/Notes server and went through their
    procedures for setting up an LDAP referral. I wanted to see if I could get
    Lotus Notes to return a referral, pointing my LDAP client to my MS Exchange
    server. Something like the following:

    1) Index the Names.nsf directory database.
    2) Add LDAP to start-up config in Notes.ini file.
    3) Create Directory Assistance database. I configured this using obvious
    tcpip info for my exchange server (which had LDAP disabled at site level,
    enabled at server level). Also, I didn't add ANY Rules to the DA document
    (all *).
    4) Restart server.
    5) Using Outlook, I queried the Lotus Notes server for user that only existed
    on MS Exchange server.
    6) According to 'show stat ldap' a referral was returned.
    7) Outlook then followed the referral and returned info from the MS Exchange
    server. (Smart-referral enabled, I guess).

    So this worked on Lotus with little difficulty by following their instructions.
    My main problem was being completely unfamiliar with Lotus product. Also,
    was forgetting to restart server and thus the LDAP process after (re)configuration.
    (Once it was working you can see reference to the referral server when LDAP
    is initializing.)

    But back to setting up referral on MS Exchange. I follow their instructions
    and nada, zip. No helpful documents in the knowledge base either.

    Anybody know if their is a registry mod that gets Exchange to return the
    referrals?

    BTW, after much headache with suck-*** Netscape Directory Server (NT version)
    I finally got referrals set up on it as well. However, it only works when
    the directory server is working...

    "Brad Perkins" <brad@necusa.com> wrote:
    >
    >Hello,
    >
    >Anybody been succesful in setting up LDAP referrals on Exchange 5.5? I've
    >got a Netscape Directory Server (LDAP server) that I've populated with some
    >test users. I have configured the Exchange 5.5 LDAP referral to point to
    >this Netscape server. When I use my LDAP client to search for name in Exchange
    >directory that only exists on the Netscape Server, Exchange never comes

    back
    >with any results. It always says there is no match.
    >
    >Is there a trick to this?
    >
    >Thanks,
    >Brad


    Share on Google+

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center