Error Message: Not a table


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 5 of 5

Thread: Error Message: Not a table

  1. #1
    Louis Guest

    Error Message: Not a table


    Hi,

    I desperately need some help, I have been working on a form for the past
    10 days and I've put a good 7 or 8 hours worth of work on this form. Today
    I was woking on it then I saved it and exited VFP 6.0. My brother came by
    and accidentally unplugged my computer without shutting down and I thought
    everything was fine since I exited VFP.

    Later on I went to work on my form and when I click on modify to modify the
    form nothing happened, when I clicked on run I got this following message:
    "Not a table."

    All other forms work fine.

    What do I do?

    Please help,

    Louis

    PS I do have a back up copy of it but that was when I had only put like 1
    hour worth of work.

  2. #2
    Nancy Folsom Guest

    Re: Error Message: Not a table

    On 21 Feb 2002 12:05:53 -0800, "Louis" <xprssyrslf@hotmail.com> wrote:

    >
    > Hi,
    >
    > I desperately need some help, I have been working on a form for the past
    > 10 days and I've put a good 7 or 8 hours worth of work on this form. Today
    > I was woking on it then I saved it and exited VFP 6.0. My brother came by
    > and accidentally unplugged my computer without shutting down and I thought
    > everything was fine since I exited VFP.


    But OS's cache data, too.

    > Later on I went to work on my form and when I click on modify to modify the
    > form nothing happened, when I clicked on run I got this following message:
    > "Not a table."


    Abri has a fox table repair utility
    (http://www.abri.com/recover.html). There are others, I think.

    >
    > All other forms work fine.
    >
    > What do I do?


    After you get your form back, run, don't walk, and install a version
    control software like Visual Sourcesafe.

    Sorry to hear it. I just lost 5 hours worth of work yesterday, and I'm
    kicking myself I hadn't been checking my changes in to VSS every 1/2
    hour or so.

  3. #3
    Al Lambert Guest

    Re: Error Message: Not a table

    http://fox.wikis.com/wc.dll?Wiki~NotATable~VFP


    http://fox.wikis.com/wc.dll?Wiki~Tab...epairTools~VFP

    HTH

    > All other forms work fine.
    >
    > What do I do?
    >
    > Please help,
    >
    > Louis
    >





  4. #4
    LouisC Guest

    Re: Error Message: Not a table


    Thanks for your help, but the file had null values all over the place. I have
    already redone the whole thing.

    Louis


    "Louis" <xprssyrslf@hotmail.com> wrote:
    >
    >Hi,
    >
    >I desperately need some help, I have been working on a form for the past
    >10 days and I've put a good 7 or 8 hours worth of work on this form. Today
    >I was woking on it then I saved it and exited VFP 6.0. My brother came

    by
    >and accidentally unplugged my computer without shutting down and I thought
    >everything was fine since I exited VFP.
    >
    >Later on I went to work on my form and when I click on modify to modify

    the
    >form nothing happened, when I clicked on run I got this following message:
    >"Not a table."
    >
    >All other forms work fine.
    >
    >What do I do?
    >
    >Please help,
    >
    >Louis
    >
    >PS I do have a back up copy of it but that was when I had only put like

    1
    >hour worth of work.



  5. #5
    Joe \Nuke Me Xemu\ Foster Guest

    Re: Error Message: Not a table

    "Nancy Folsom" <nancy_folsom@hotmail.com> wrote in message <news:ntoa7u0geu2slaplv63uec4offk1ugrbi4@4ax.com>...

    > On 21 Feb 2002 12:05:53 -0800, "Louis" <xprssyrslf@hotmail.com> wrote:


    > > I desperately need some help, I have been working on a form for the past
    > > 10 days and I've put a good 7 or 8 hours worth of work on this form. Today
    > > I was woking on it then I saved it and exited VFP 6.0. My brother came by
    > > and accidentally unplugged my computer without shutting down and I thought
    > > everything was fine since I exited VFP.

    >
    > But OS's cache data, too.


    Not if the app tells the OS not to, perhaps because it's doing its own
    caching. Check out FILE_FLAG_WRITE_THROUGH and FILE_FLAG_NO_BUFFERING:

    URL:http://msdn.microsoft.com/library/en...lesio_7wmd.asp

    Of course, if VFP's low-level file I/O layer isn't already savvy about
    them, asking MSFT to fix it might not be a smart idea: You can't know
    what else Hejlsberg might decide to "fix". (In the veterinary sense!)

    Be careful what you wish for... =/

    --
    Joe Foster <mailto:jlfoster%40znet.com> Got Thetans? <http://www.xenu.net/>
    WARNING: I cannot be held responsible for the above They're coming to
    because my cats have apparently learned to type. take me away, ha ha!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center