3D photo cube applet


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 3 of 3

Thread: 3D photo cube applet

  1. #1
    Join Date
    Sep 2002
    Posts
    2

    Post 3D photo cube applet

    I am setting up a family homepage, on which I want to use an applet called "3d photo cube" (downloaded from this site). It allows you to display up to 6 photos on a rotating cube; viewers then click on any face of the cube to view a particular photo.

    The problem I have is that, when I view the files locally on my home PC (on which I created the site), the applet works fine; when I view on my work PC, it also works fine. But when I try to view it on the web on my home PC (via a dial-up connection), it doesn't work - it starts to load the images into the applet and then just stops part-way through, and I'm just left with the grey box saying "loading image 2" etc.

    Does anyone have any idea what the problem may be? The only key difference I can think of between my home and work PCs is that Internet access at work is via a very fast permanent connection, whereas at home it's via dial-up on a 56k modem.

    You can see the applet by going to homepage.ntlworld.com/rob.grayson/index.htm and then selecting either "Joseph" or "Bethany".

    Thanks in anticipation,
    -----------

    Rob G

  2. #2
    Join Date
    Jul 2002
    Posts
    60

    Arrow

    Hello Rob,
    Nice family you have there
    I saw everyone, depicted on both applets, on both pages. Quite honestly I can't visualize your problem... it works perfectly! But then again, I'm using MSIE 6 over a DSL line. You may have the key to it, re: your images. I started to check out the size of each of the 6-images in your applets, but my own family begged for attention and I had to leave. So, you might check that out, try optimizing and making your jpegs smaller. I did notice that the order of the params on one page are different than the order on the other. It doesn't seem that it would make too much difference for this program...

    Oh, your daughter's page did not load on the first try; second time around, it came through just fine. Successive trys, after the class and other files were in my temporary-internet-files (cache) folder, did just fine!!
    Great job... hope it keeps working for you!

  3. #3
    Join Date
    Sep 2002
    Posts
    2
    Thanks for your thoughts. I logged on at home last night, and lo and behold, the applet worked fine on both pages! I have no idea why it worked this time and not previously, and I can't get it not to work any more. So I guess I should be happy...

    I will look at reducing the file size of the images, though.

    Thanks again,
    -----------

    Rob G

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center