Java Applet won't work via browsers


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: Java Applet won't work via browsers

  1. #1
    Graham Guest

    Java Applet won't work via browsers


    I have written a Java Applet using JDK 1.2.2 It compiles cleanly with no
    deprecated methods or anything. I created an html file to run the applet
    and when I run this using the appletviewer in JDK 1.2.2, and it works perfectly.
    However, the same html, when veiwed through either IE5 or Netscape (Communicator
    4.6) shows the applet box, and indicates 'Applet Started' in the status bar,
    but the applet doesn't appear to run (or if it is running, I can't see it).
    I have tried running the sample html files that come with JDK 1.2.2 the
    same way, and they all work fine, so I know my browsers are set up to run
    Java - where am I going wrong? Has anyone had similar problems?

    Any help, advice, or even sympathy, would be gratefully received!

    Graham.

  2. #2
    Rajkamal Gopinath Guest

    Re: Java Applet won't work via browsers


    Hi,

    The problem is IE or Netscape does not support JDK1.2.2 directly, if you
    wish to run programs targetted for JDK1.2 you need a JDK1.2 plugins

    Even when JDK1.2 Plug-In is installed, the Applet tag won't work with JDK1.2,
    you need to use OBJECT Tag..

    There is tool call HTMLConverter which can automatically convert your APPLET
    TAG with the OBJECT TAG if you specify the HTML file

    Download the JDK1.2 Plugin and HTML Converter from SUN Downloads

    Hope this helps.

    Regards

    Rajkamal



    "Graham" <Graham.Smith@Pfizer.com> wrote:
    >
    >I have written a Java Applet using JDK 1.2.2 It compiles cleanly with no
    >deprecated methods or anything. I created an html file to run the applet
    >and when I run this using the appletviewer in JDK 1.2.2, and it works perfectly.
    > However, the same html, when veiwed through either IE5 or Netscape (Communicator
    >4.6) shows the applet box, and indicates 'Applet Started' in the status

    bar,
    >but the applet doesn't appear to run (or if it is running, I can't see it).
    > I have tried running the sample html files that come with JDK 1.2.2 the
    >same way, and they all work fine, so I know my browsers are set up to run
    >Java - where am I going wrong? Has anyone had similar problems?
    >
    >Any help, advice, or even sympathy, would be gratefully received!
    >
    >Graham.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center