I have installed Java Web server 2.0 on win 98. I have a strange problem wih
it.
I have set my CLASSPATH in autoexec.bat as
set CLASSPATH = c:\JavaWebServer2.0\lib\servlet.jar;%CLASSPATH%
now If I try to compile a servlet, its gives me error ie javax.servlet.*;
& javax.servlet.http.*; not found.
Now I tried to print my classpath from Java Program
System.out.println(System.getProperty("java.class.path"));
, when I executed this program it printed simple a "." . which means that
classpath is not set.
then I made a change in autoexec.bat and set classpath as
set CLASSPATH=c:\JavaWebServer2.0\lib\servlet.jar;%CLASSPATH% ( removed spaces)
& rebooted my machine
after rebooting, I tried to compile my servlet, and it got compiled, so now
my CLASSPATH is set , but if now I try to execute
any java program ( the program that print the classpath at run time, upper
program), it wont execute.
seems to me that setting my own CLASSPATH would override the internal classpath
of JVM( invisible to user) , so
consequently , the java program wont execute. I am still having no problem
in compiling the program
Any suggestion
Thanx in advance
Sami