hi,
i'm still confused when i have to deploy a webservice i coded.
this time, it doesn't works, again. i try to way to create the deploymentdescriptor
: with IBM WSDL generator and by myself.
The problem i do have with WSDL gen is : the class i want to make available
from the webservice returns to the client part a Vector of Company (a type
i defined).
when in the interface i select the class, and then the method, i'm asked
to select types in the wrapper complex type tab. In this list i get the Vector
type. Weird ??? i thought that Vector where recognized and had no mapping
needed ?? so i select it, and then i go this error :

com.ibm.xmlsm.SchemaUnsupportedException: The following type of primitive
element is not supported:"http://www.w3.org/2001/XMLSchema:[Ljava.lang.Object;".



Really weird. So i tried to make the deploymentdescriptor myself, and defined
it this way :

<isd:service xmlns:isd="http://xml.apache.org/xml-soap/deployment" id="urn:liox:CompanyList"
checkMustUnderstands="false">
<isdrovider type="java" scope="Application" methods="mainrun">

<isd:java class="lionbridge.pl.cl.GetCompanyListServer" static="false"/>

</isdrovider>
<isd:mappings>
<isd:map encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:x="urn:Companys" qname="x:Company" javaType="lionbridge.type.Company"
xml2JavaClassName="lionbridge.type.CompanySerializer" java2XMLClassName="lionbridge.type.CompanySerializer"/>

</isd:mappings>
</isd:service>

when then i deploy it, verify it's deployed, and launch the client side,
the result is :

Invoke service
URL= http://localhost:8080/soap/servlet/rpcrouter
URN= urn:liox:CompanyList
Ouch, the call failed:
Fault Code = SOAP-ENV:Server.BadTargetObjectURI
Fault String = Unable to resolve target object:


So what's wrong ?
regards