Splash screen won't load


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 3 of 3

Thread: Splash screen won't load

  1. #1
    B.Fenella Guest

    Splash screen won't load

    My splash screen isn't fully loading before the main form loads.
    The splash screen caption bar appears but the rest of the screen is
    transparent.
    I'm displaying a splash screen at the beginning of my startup module, but
    most of the startup work is done when I load the first form. The main form
    has to scale and draw several maps whilst it is loading which takes ages.
    I need my splash screen to load and then stay visible until I've loaded the
    main form.

    Does anyone know what I'm doing wrong?

    Thanks in advance for any help,

    Fen

  2. #2
    Rick Rothstein Guest

    Re: Splash screen won't load

    Right after you Show your splash screen, Refresh it.

    frmYourSplashScreen.Show
    frmYourSplashScreen.Refresh
    '
    ' The rest of your code goes here
    '

    Rick


    "B.Fenella" <ucs801@bangor.ac.uk> wrote in message
    news:3909A481.27E2CBEB@bangor.ac.uk...
    > My splash screen isn't fully loading before the main form loads.
    > The splash screen caption bar appears but the rest of the screen is
    > transparent.
    > I'm displaying a splash screen at the beginning of my startup module, but
    > most of the startup work is done when I load the first form. The main form
    > has to scale and draw several maps whilst it is loading which takes ages.
    > I need my splash screen to load and then stay visible until I've loaded

    the
    > main form.
    >
    > Does anyone know what I'm doing wrong?
    >
    > Thanks in advance for any help,
    >
    > Fen




  3. #3
    B.Fenella Guest

    Re: Splash screen won't load



    Thanks, that worked. I wasn't expecting such a simple solution!


    Rick Rothstein wrote:
    >
    > Right after you Show your splash screen, Refresh it.
    >
    > frmYourSplashScreen.Show
    > frmYourSplashScreen.Refresh
    > '
    > ' The rest of your code goes here
    > '
    >
    > Rick
    >
    > "B.Fenella" <ucs801@bangor.ac.uk> wrote in message
    > news:3909A481.27E2CBEB@bangor.ac.uk...
    > > My splash screen isn't fully loading before the main form loads.
    > > The splash screen caption bar appears but the rest of the screen is
    > > transparent.
    > > I'm displaying a splash screen at the beginning of my startup module, but
    > > most of the startup work is done when I load the first form. The main form
    > > has to scale and draw several maps whilst it is loading which takes ages.
    > > I need my splash screen to load and then stay visible until I've loaded

    > the
    > > main form.
    > >
    > > Does anyone know what I'm doing wrong?
    > >
    > > Thanks in advance for any help,
    > >
    > > Fen


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center