Web services


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 4 of 4

Thread: Web services

  1. #1
    madhu Guest

    Web services


    Hi,

    I have made a web service however i am unable to use the Add Web Referance
    tab in my Client application.
    I will get the following error message

    On my left side i see the pages and functions i.e on IE
    But to my right i.e Available Web reference i get the following error message.


    Web Services

    (none)
    No Web References were found on this page.
    Click for help on finding a Web Reference.


    Errors

    The document at the url http://localhost/fresno/service1.asmx was not recognized
    as a known document type.
    The error message from each known type may help you fix the problem:
    - Report from 'WSDL Document' is 'A Service Description was not found at
    the URL http://localhost/fresno/service1.asmx.'.
    - The content type 'text/html; charset=utf-8' is not valid for an XML document.
    - Report from 'DISCO Document' is 'There was an error downloading 'http://localhost/fresno/service1.asmx?disco'.'.
    - The request failed with the error message:
    --
    <html>
    <head>
    <title>Server Unavailable
    </title>
    </head>
    <body>
    <h1><font face=Verdana color=#ff3300>Server Application Unavailable
    </font></h1>
    <p>
    <font face=Verdana>
    The web application you are attempting to access on this web server
    is currently unavailable.&nbsp; Please hit the "Refresh" button in your web
    browser to retry your request.
    </p>
    <p>
    <b>Administrator Note:
    </b> An error message detailing the cause of this specific request failure
    can be found in the system event log of the web server. Please review this
    log entry to discover what caused this error to occur.
    </p>
    </body>
    </html>

    --.
    - Report from 'XML Schema' is 'A schema could not be found at the URL http://localhost/fresno/service1.asmx.'.
    - The content type 'text/html; charset=utf-8' is not valid for an XML document.




    CAN ANY ONE PLEASE HELP ME WITH ABOVE ERROR MESSAGE

    I did reinstall SDK and VS.net but i still get the error.


    Thank you


  2. #2
    Maninder Guest

    Re: Web services


    "madhu" <madhavipathi@yahoo.com> wrote:
    >
    >Hi,
    >
    >I have made a web service however i am unable to use the Add Web Referance
    >tab in my Client application.
    >I will get the following error message
    >
    >On my left side i see the pages and functions i.e on IE
    >But to my right i.e Available Web reference i get the following error message.
    >
    >
    >Web Services
    >
    >(none)
    >No Web References were found on this page.
    >Click for help on finding a Web Reference.
    >
    >
    >Errors
    >
    >The document at the url http://localhost/fresno/service1.asmx was not recognized
    >as a known document type.
    >The error message from each known type may help you fix the problem:
    >- Report from 'WSDL Document' is 'A Service Description was not found at
    >the URL http://localhost/fresno/service1.asmx.'.
    > - The content type 'text/html; charset=utf-8' is not valid for an XML

    document.
    >- Report from 'DISCO Document' is 'There was an error downloading 'http://localhost/fresno/service1.asmx?disco'.'.
    > - The request failed with the error message:
    >--
    ><html>
    > <head>
    > <title>Server Unavailable
    ></title>
    > </head>
    > <body>
    > <h1><font face=Verdana color=#ff3300>Server Application Unavailable
    ></font></h1>
    > <p>
    > <font face=Verdana>
    > The web application you are attempting to access on this web server
    >is currently unavailable.* Please hit the "Refresh" button in your web
    >browser to retry your request.
    ></p>
    > <p>
    > <b>Administrator Note:
    ></b> An error message detailing the cause of this specific request failure
    >can be found in the system event log of the web server. Please review this
    >log entry to discover what caused this error to occur.
    > </p>
    > </body>
    ></html>
    >
    >--.
    >- Report from 'XML Schema' is 'A schema could not be found at the URL http://localhost/fresno/service1.asmx.'.
    > - The content type 'text/html; charset=utf-8' is not valid for an XML

    document.
    >
    >
    >
    >
    >CAN ANY ONE PLEASE HELP ME WITH ABOVE ERROR MESSAGE
    >
    >I did reinstall SDK and VS.net but i still get the error.
    >
    >
    >Thank you
    >


    Hello Madhu, This is not a error But a settings Problem. Here do this and
    I hope the Problem Will be solved For ever..

    Goto Winnt/Microsoft.net/FrameWork/v1.0.3705/CONFIG/

    1) The v1.0.3705 Folder can Be any version depending upon the Version number
    of Dot net U have installed.. Actuallt it Does not matter Just go directly
    to the Config Folder.
    2) Open the File Machine.config (Any editor)

    Find or Goto :
    <httpHandlers><!--<add verb="*" path="*.vsdisco" type="System.Web.Services.Discovery.DiscoveryRequestHandler,
    System.Web.Services, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    validate="false"/>-->

    Uncomment the Line to Look like this:

    <httpHandlers><add verb="*" path="*.vsdisco" type="System.Web.Services.Discovery.DiscoveryRequestHandler,
    System.Web.Services, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    validate="false"/>

    Thats it : Now save and happy Webservices Programming.
    PS: Pl. Do let me know if this Works.

    Thankyou
    Maninder Dhanjal

  3. #3
    madhavi pathi Guest

    Re: Web services



    Nice try sorry it did not work. I did this before but there was no use. Actually
    i replaced my config file with one of my friends that works but no use.

    I am so tired of fixing this problem. can you please help.
    Do you have any other solution?

    Thank you.

    "Maninder" <msdhanjal@yahoo.com> wrote:
    >
    >"madhu" <madhavipathi@yahoo.com> wrote:
    >>
    >>Hi,
    >>
    >>I have made a web service however i am unable to use the Add Web Referance
    >>tab in my Client application.
    >>I will get the following error message
    >>
    >>On my left side i see the pages and functions i.e on IE
    >>But to my right i.e Available Web reference i get the following error message.
    >>
    >>
    >>Web Services
    >>
    >>(none)
    >>No Web References were found on this page.
    >>Click for help on finding a Web Reference.
    >>
    >>
    >>Errors
    >>
    >>The document at the url http://localhost/fresno/service1.asmx was not recognized
    >>as a known document type.
    >>The error message from each known type may help you fix the problem:
    >>- Report from 'WSDL Document' is 'A Service Description was not found at
    >>the URL http://localhost/fresno/service1.asmx.'.
    >> - The content type 'text/html; charset=utf-8' is not valid for an XML

    >document.
    >>- Report from 'DISCO Document' is 'There was an error downloading 'http://localhost/fresno/service1.asmx?disco'.'.
    >> - The request failed with the error message:
    >>--
    >><html>
    >> <head>
    >> <title>Server Unavailable
    >></title>
    >> </head>
    >> <body>
    >> <h1><font face=Verdana color=#ff3300>Server Application Unavailable
    >></font></h1>
    >> <p>
    >> <font face=Verdana>
    >> The web application you are attempting to access on this web server
    >>is currently unavailable.* Please hit the "Refresh" button in your web
    >>browser to retry your request.
    >></p>
    >> <p>
    >> <b>Administrator Note:
    >></b> An error message detailing the cause of this specific request failure
    >>can be found in the system event log of the web server. Please review

    this
    >>log entry to discover what caused this error to occur.
    >> </p>
    >> </body>
    >></html>
    >>
    >>--.
    >>- Report from 'XML Schema' is 'A schema could not be found at the URL http://localhost/fresno/service1.asmx.'.
    >> - The content type 'text/html; charset=utf-8' is not valid for an XML

    >document.
    >>
    >>
    >>
    >>
    >>CAN ANY ONE PLEASE HELP ME WITH ABOVE ERROR MESSAGE
    >>
    >>I did reinstall SDK and VS.net but i still get the error.
    >>
    >>
    >>Thank you
    >>

    >
    >Hello Madhu, This is not a error But a settings Problem. Here do this and
    >I hope the Problem Will be solved For ever..
    >
    >Goto Winnt/Microsoft.net/FrameWork/v1.0.3705/CONFIG/
    >
    >1) The v1.0.3705 Folder can Be any version depending upon the Version number
    >of Dot net U have installed.. Actuallt it Does not matter Just go directly
    >to the Config Folder.
    >2) Open the File Machine.config (Any editor)
    >
    >Find or Goto :
    > <httpHandlers><!--<add verb="*" path="*.vsdisco" type="System.Web.Services.Discovery.DiscoveryRequestHandler,
    >System.Web.Services, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    >validate="false"/>-->
    >
    >Uncomment the Line to Look like this:
    >
    > <httpHandlers><add verb="*" path="*.vsdisco" type="System.Web.Services.Discovery.DiscoveryRequestHandler,
    >System.Web.Services, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    >validate="false"/>
    >
    >Thats it : Now save and happy Webservices Programming.
    >PS: Pl. Do let me know if this Works.
    >
    >Thankyou
    >Maninder Dhanjal



  4. #4
    madhavi pathi Guest

    Re: Web services



    Hi Ed,

    Now i can see the web reference but when i click add reference i get error
    message in event viewer System log as follows.

    The IIS Admin Service service terminated unexpectedly. It has done this
    1 time(s). The following corrective action will be taken in 0 milliseconds:
    No action.

    EventID is 7031
    The FTP Publishing Service service terminated unexpectedly. It has done
    this 1 time(s). The following corrective action will be taken in 0 milliseconds:
    No action.

    The Simple Mail Transport Protocol (SMTP) service terminated unexpectedly.
    It has done this 1 time(s). The following corrective action will be taken
    in 0 milliseconds: No action.

    The World Wide Web Publishing Service service terminated unexpectedly. It
    has done this 1 time(s). The following corrective action will be taken in
    0 milliseconds: No action.


    I applied Code red 2 patch from microsoft. After that i get different error
    in application log in event viewer as

    aspnet_wp.exe (PID: 1152) stopped unexpectedly. event id as 1000

    Do you have any solution? Please help me.



    "Maninder" <msdhanjal@yahoo.com> wrote:
    >
    >"madhu" <madhavipathi@yahoo.com> wrote:
    >>
    >>Hi,
    >>
    >>I have made a web service however i am unable to use the Add Web Referance
    >>tab in my Client application.
    >>I will get the following error message
    >>
    >>On my left side i see the pages and functions i.e on IE
    >>But to my right i.e Available Web reference i get the following error message.
    >>
    >>
    >>Web Services
    >>
    >>(none)
    >>No Web References were found on this page.
    >>Click for help on finding a Web Reference.
    >>
    >>
    >>Errors
    >>
    >>The document at the url http://localhost/fresno/service1.asmx was not recognized
    >>as a known document type.
    >>The error message from each known type may help you fix the problem:
    >>- Report from 'WSDL Document' is 'A Service Description was not found at
    >>the URL http://localhost/fresno/service1.asmx.'.
    >> - The content type 'text/html; charset=utf-8' is not valid for an XML

    >document.
    >>- Report from 'DISCO Document' is 'There was an error downloading 'http://localhost/fresno/service1.asmx?disco'.'.
    >> - The request failed with the error message:
    >>--
    >><html>
    >> <head>
    >> <title>Server Unavailable
    >></title>
    >> </head>
    >> <body>
    >> <h1><font face=Verdana color=#ff3300>Server Application Unavailable
    >></font></h1>
    >> <p>
    >> <font face=Verdana>
    >> The web application you are attempting to access on this web server
    >>is currently unavailable.* Please hit the "Refresh" button in your web
    >>browser to retry your request.
    >></p>
    >> <p>
    >> <b>Administrator Note:
    >></b> An error message detailing the cause of this specific request failure
    >>can be found in the system event log of the web server. Please review

    this
    >>log entry to discover what caused this error to occur.
    >> </p>
    >> </body>
    >></html>
    >>
    >>--.
    >>- Report from 'XML Schema' is 'A schema could not be found at the URL http://localhost/fresno/service1.asmx.'.
    >> - The content type 'text/html; charset=utf-8' is not valid for an XML

    >document.
    >>
    >>
    >>
    >>
    >>CAN ANY ONE PLEASE HELP ME WITH ABOVE ERROR MESSAGE
    >>
    >>I did reinstall SDK and VS.net but i still get the error.
    >>
    >>
    >>Thank you
    >>

    >
    >Hello Madhu, This is not a error But a settings Problem. Here do this and
    >I hope the Problem Will be solved For ever..
    >
    >Goto Winnt/Microsoft.net/FrameWork/v1.0.3705/CONFIG/
    >
    >1) The v1.0.3705 Folder can Be any version depending upon the Version number
    >of Dot net U have installed.. Actuallt it Does not matter Just go directly
    >to the Config Folder.
    >2) Open the File Machine.config (Any editor)
    >
    >Find or Goto :
    > <httpHandlers><!--<add verb="*" path="*.vsdisco" type="System.Web.Services.Discovery.DiscoveryRequestHandler,
    >System.Web.Services, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    >validate="false"/>-->
    >
    >Uncomment the Line to Look like this:
    >
    > <httpHandlers><add verb="*" path="*.vsdisco" type="System.Web.Services.Discovery.DiscoveryRequestHandler,
    >System.Web.Services, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    >validate="false"/>
    >
    >Thats it : Now save and happy Webservices Programming.
    >PS: Pl. Do let me know if this Works.
    >
    >Thankyou
    >Maninder Dhanjal



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center