Why Session timeout does't work?.


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 10 of 10

Thread: Why Session timeout does't work?.

  1. #1
    srikan11 Guest

    Why Session timeout does't work?.


    i have set the session time out in web.comfig file as

    <sessionState mode="InProc" cookieless="false" timeout="20" />

    it doesn't work at all , I just let open the window, look at the clock if
    I do nothing , 10 minutes later I am thrown away from the session , the values
    are lost !

    how can I do that ?, I really need a longer timeout
    how do i do it?.

    thank you


  2. #2
    Greg Rothlander Guest

    Re: Why Session timeout does't work?.


    I'm having a similar problem. If you have figured this out or if you figure
    it out... can you forward the answer to me? I'll do the same!

    Thanks,
    Greg Rothlander

    "srikan11" <srikan11@yahoo.com> wrote:
    >
    >i have set the session time out in web.comfig file as
    >
    ><sessionState mode="InProc" cookieless="false" timeout="20" />
    >
    >it doesn't work at all , I just let open the window, look at the clock if
    >I do nothing , 10 minutes later I am thrown away from the session , the

    values
    >are lost !
    >
    >how can I do that ?, I really need a longer timeout
    >how do i do it?.
    >
    >thank you
    >



  3. #3
    Join Date
    Oct 2005
    Posts
    3
    hi srikan

    i too have the same session timeoutproblem if i get a solution i will put it up here and if u get it then please put it here or mail at (gaur.seema at rediffmail.com).
    Even i am struggling with this problem and dont know the solution yet

    Seema

  4. #4
    Join Date
    Oct 2005
    Posts
    3
    i am using session variables that i set in global.asax and then i set it to any value to identify that login is validand i check it in all pages whcih can viewed only after login.

    In web.config file: U can set the session state timeout value.
    And also set <pages enableSessionState="true"/>

    i hope it helps
    Seema

  5. #5
    Join Date
    Apr 2008
    Posts
    1
    I have same problem. I use asp , when I set up session.timeout = 480 in common.asp file. it doesn't work at all . can someone help for this problem with asp? how can I fix this problem??

  6. #6
    Join Date
    Apr 2008
    Posts
    1
    In .NET, there is an additional setting for this. The default script timeout is set to 90 seconds by the httpRuntime section of the machine.config file. You can change this setting to affect all applications on your site, or you can override the settings in your application-specific web.config as follows:

    <system.web>
    <httpRuntime executionTimeout="9000" />
    </system.web>

    The .NET config files are usually stored in the folder C:\Windows\Microsoft.NET\Framework\[version]\Config where [version] is the version of the .NET Framework such as v1.1.4322. You may need to restart IIS for such changes to take effect.

  7. #7
    Join Date
    Apr 2008
    Posts
    4
    If this is an option or solution for this question. I found it on first google search I did.

    {
    Go to the website in question, right-click and choose "Properties".
    Click on the "Home Directory" tab
    Click on the "Configuration" button
    Click on the "App Options" tab on the pop-up window
    Choose the session timeout you wish. As you can see on this screen, the
    default value built into IIS 5.0 out of the box is "xx" minutes.
    }
    Last edited by Czew; 04-21-2008 at 02:38 PM.

  8. #8
    Join Date
    May 2008
    Posts
    2

    Reset IIS

    I had the same issue, and it seems the problem has to do with resetting IIS. Until the web server is restarted, the server settings of 20 minutes still remained.

  9. #9
    Join Date
    May 2008
    Posts
    4
    Hi,

    When project is running in DEBUG mode all timeouts are disabled.

    So, try this:

    1. In web.config file: <compilation debug="false" defaultLanguage="your project's lenguage">

    2. Run project in RELEASE mode.

    Hope this helps.

  10. #10
    Join Date
    May 2008
    Posts
    2

    Thumbs up

    Thanks a lot for posting.

    After my last post, I realized the timeout was still stopping at 20minutes, and thought that somehow the timeout value was being bounced back and forth between the web.config and the server setting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center