Controls do NOT FIRE in DIV tag?


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: Controls do NOT FIRE in DIV tag?

Hybrid View

  1. #1
    k Guest

    Controls do NOT FIRE in DIV tag?


    Hi
    I have a couple of web pages and all controls on the web page are included
    in a DIV tag. i.e., I created a DIV tag first and then started inserting
    each control into this tag. When user changes the View-TextSize-largest this
    method of DIV tag helps in adjusting the font sizes etc (otherwise the fonts
    all get screwed with labels falling one over the other). The hyperlinks inside
    the DIV tag do not fire sometimes and do fire sometimes. I also use session
    variables and all the code and variables are showing no errors. Session timeout
    is set at 20.

    I MUST use smartNavigation to have the radio buttons fire and run a code
    on CBC C# file. Everything is fine except that the controls do not fire.
    Wonder also is that, on the same page some controls fire and some do not.
    All properties of firinig control are identical as the control that does
    not fire except name etc. I replaced the DIV with SPAN and the problem remains
    the same. Autopost back IS TRUE for all controls also.

    Any help is greatly appreciated. I am way behind my project already. :-(

  2. #2
    Russell Jones Guest

    Re: Controls do NOT FIRE in DIV tag?

    In your message, you first say "hyperlinks" don't fire, and then you say
    "controls" do not fire. What are you trying to do? You also say that you
    MUST use SmartNavigation. Does your page work *without* SmartNavigation
    turned on? SmartNavigation runs script when the page loads to make it appear
    as if the page didn't refresh completely. Sometimes that script interferes
    with existing script that you want the page to run when it loads. Do you
    have any client-side script that must run to initialize the page?

    "k" <vb.@127.0.0.1> wrote in message news:3edf569f$1@tnews.web.devx.com...
    >
    > Hi
    > I have a couple of web pages and all controls on the web page are included
    > in a DIV tag. i.e., I created a DIV tag first and then started inserting
    > each control into this tag. When user changes the View-TextSize-largest

    this
    > method of DIV tag helps in adjusting the font sizes etc (otherwise the

    fonts
    > all get screwed with labels falling one over the other). The hyperlinks

    inside
    > the DIV tag do not fire sometimes and do fire sometimes. I also use

    session
    > variables and all the code and variables are showing no errors. Session

    timeout
    > is set at 20.
    >
    > I MUST use smartNavigation to have the radio buttons fire and run a code
    > on CBC C# file. Everything is fine except that the controls do not fire.
    > Wonder also is that, on the same page some controls fire and some do not.
    > All properties of firinig control are identical as the control that does
    > not fire except name etc. I replaced the DIV with SPAN and the problem

    remains
    > the same. Autopost back IS TRUE for all controls also.
    >
    > Any help is greatly appreciated. I am way behind my project already. :-(




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center