Cannot compile the javax packages


DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: Cannot compile the javax packages

  1. #1
    Join Date
    Mar 2004
    Posts
    1

    Unhappy Cannot compile the javax packages

    Hi,
    I installed the Netbeans 3.5.1, which uses the JDK 1.4.2.After the installation i tried to run a bean program , which fails to compile saying the package cannot be found. I tried to put the package in the classpath also, but that also failed.
    I experienced similar problem when running Java Mail API's. I beleive that the packages will be internally set by the Netbeans IDE.
    Is there any other way to make them work.
    I use Windows 2000 Professional.

    Thanking You in anticipation,

  2. #2
    Join Date
    Feb 2004
    Posts
    541
    i had a problem with packages recently in that they "didn't exist" according to the compiler, even though i'd added the relevant path to the classpath. It turned out that the classpath as java saw it was only loaded once, so if i changed the classpath AFTER java had started then java didn't know about it. After i logged out then back in again it all worked fine. No idea if this will help, but thought i'd share anyway. Hope you sort it out

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center