DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 3 of 3

Thread: Error 20997

  1. #1
    Join Date
    Aug 2004

    Error 20997

    [Originally posted by Naiada Zeneli]

    I have created a report using Crystal Report 8.5.
    When i tried to save in the disk I get the error
    20997 cpeaut32. But I had saved it long time ago without any problem. Can anybody help me to find what is going on ?

  2. #2
    Join Date
    Aug 2004

    Re:Error 20997

    [Originally posted by Paul Ruffalo]

    Have you resolved your issue yet? We are having a similar problem. One of our supervisors cannot run a report on her machine, but the report works everywhere else. The only error she recieves is error #20997. Any ideas?

  3. #3
    Join Date
    Aug 2004

    Re:Error 20997

    [Originally posted by Larry Asher]

    cpeaut32 is a dll file it may be that it is missing or has became corrupted or improperly installed.

    First, I would do a search for cpeaut32.dll and see what you find. If found, I would try running regsvr32 and see what kind of message you get. From the Start menu, Run, regsvr32 cpeaut32.dll this will attempt to register the dll.

    If not found then you know there is an install problem. Also, I would look at the help documentation for developers that came with Crystal Reports. There is a section in there addressing dependencies, redistributables, and related information.

    Unfortunately, it has been awhile since I have worked with Crystal Reports. I hope this can help, let me know how it turns out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center
Latest Articles
Questions? Contact us.
Web Development
Latest Tips
Open Source

   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center