Hello I have an very irritating problem (or lack of knowledge)

I use Eclipse (but have tried both NetBeans and JCreator with the same result). I have installed JDK 5.0 which I downloaded form java.sun.com

Hmm, I'll try to describe my problem.

When I wrote an applet and tried to view it it worked first very well on my computer, after the installation of the JDK a new setting in Internet Explorer was set: -> Use JRE 1.5 for applets. As long as it is enabled viewing applets works well from my computer, but when I turn it off none of my applet works, but other applets (form tutorials etc etc) still works fine.

The reason this is a problem is that it seems that my applets don't work on computers which has not installed the JDK. And since they are using the same version of browser (IE 6.0) as me I don't really get it. First I thought it may be something with my code but I downloaded some other applet source code from internet and tried to compile it but it did not work (but the .class files included with the source code worked fine)

So, I really appritiate some help here, any explenation of this (for me) strange behaivor, and any idea on how to work around this problem would really be great...

The problem seems to be originating from my compilers but since I tried different ones there must be some vital setting missing... The compile process seems to work fine, and .class files are produced. As I said earlier I can make them work on my computer.

Pleas I really need help on this irritating problem

Best regards