DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 4 of 4

Thread: Java Applet Compiler problem?

  1. #1
    Join Date
    Mar 2005

    Angry Java Applet Compiler problem?

    Hello I have an very irritating problem (or lack of knowledge)

    I use Eclipse (but have tried both NetBeans and JCreator with the same result). I have installed JDK 5.0 which I downloaded form

    Hmm, I'll try to describe my problem.

    When I wrote an applet and tried to view it it worked first very well on my computer, after the installation of the JDK a new setting in Internet Explorer was set: -> Use JRE 1.5 for applets. As long as it is enabled viewing applets works well from my computer, but when I turn it off none of my applet works, but other applets (form tutorials etc etc) still works fine.

    The reason this is a problem is that it seems that my applets don't work on computers which has not installed the JDK. And since they are using the same version of browser (IE 6.0) as me I don't really get it. First I thought it may be something with my code but I downloaded some other applet source code from internet and tried to compile it but it did not work (but the .class files included with the source code worked fine)

    So, I really appritiate some help here, any explenation of this (for me) strange behaivor, and any idea on how to work around this problem would really be great...

    The problem seems to be originating from my compilers but since I tried different ones there must be some vital setting missing... The compile process seems to work fine, and .class files are produced. As I said earlier I can make them work on my computer.

    Pleas I really need help on this irritating problem

    Best regards

  2. #2
    Join Date
    Mar 2005


    seems to be lack of knowledge here also

    Well, if this problem is beyond you, have you any other Ideas I can try... hmm this is frustrating... I'v tried most settings and I can not understand whats wrong... well thought I should add that the errorcode in IE is => class myApplet not found

    But I don't think that is relevant thought... May it be my compiler is compiling code for some more recent version of JRE, than built in my (and other standard) browsers???

  3. #3
    Join Date
    Feb 2005
    Most web browsers support java, windows 6.0 does and so does Firefox (which i use). A JDK is installed by the web browser so they can use java, you download SDK/ JDK to write the code. It could be your JDK is a new version so i would try upgrading your web browser JDK and see if that works. Also you might not of coded the applet to appear in the web browser.

    Java is a widely used language and java can be used on any operating system and on most browsers, updating everything should resolve this problem

  4. #4
    Join Date
    Mar 2005

    Problem has somewhat changed

    Yhea, I figured out the problem (fond the answer on a different forum), IExplorer seems to default have support for jvm 1.1 (even the more recent versions). When I downloaded the JDK (and probably also JRE) it updated my jvm to 1.5. Great that works for me, but the majority of people still got 1.1 so my problem now is to get my compiler to produce code targeted jvm 1.1

    That I haven't still figured out if i vrite -target 1.1 the compiler complains that 1.1 missmatches default setting 1.5 or some similar.

    I searched for a jdk for 1.1 but found only the docs. Suppose that my 1.5 has support for it but I can't seem to find out how to do this...

    I am using Eclipse (or JCreator) if anybody has any ideas!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
HTML5 Development Center
Latest Articles
Questions? Contact us.
Web Development
Latest Tips
Open Source

   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center