DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 4 of 4

Thread: exe will not start

  1. #1
    Join Date
    Oct 2004
    Location
    Baltimore MD
    Posts
    69

    exe will not start

    I've posted this question before but I still have no luck. I compile a program using VC++ pro. I use "depends.exe" to determine what DLLs the program is linking. Then I use the Install Shield that comes with VC++ to create a setup file and include all the DLLs and the exe. I run the setup file on my pc and it works great. My problem is that when I try to install it on any* other system, the install goes fine but when I try to run the program nothing happens. I double click and I don't see an error, the thing just doesn't do anything! This is very frustrating as you can imagine. So, if any one has had this problem in the past or if you just have a suggestion, Please let me know...

    Thanks

    -Zak

    *any pc that does not have VC++ installed...

  2. #2
    Join Date
    Dec 2003
    Posts
    3,366
    It can be one of several things.
    1) your libs are simply the wrong versions, I.E. you compiled with win 98 libs and it won't run on xp, etc.

    2) you are missing a dll that is required by some other dll, so it quietly gives up. Use dumpbin on *everything* to manually trace out the depends, or find/use some tool that tells you every dll that is opened (check out the system before you run, then run it, see what opens) (can that be done?)

    3) your program resolution is wrong, so it happily runs "off the screen" -- you will see it on taskbar if that happens unless you make it not have a taskbar entry.

    4) you used an unsupported graphics mode or some other unsupported graphics problem.

    5) you depend on something that you should know all about like a service or component.

  3. #3
    Join Date
    Oct 2004
    Location
    Baltimore MD
    Posts
    69
    I use a common dialog control for a "browse" button. Could there be something that I have to include in the setup file for it to work???

  4. #4
    Join Date
    Dec 2003
    Posts
    3,366
    possibly an ocx if its an activex control?

    But that should complain directly. It sounds mostly like dll calling dll problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center