DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 4 of 4

Thread: overcome j2se 1.3-1.4 incompatibility

  1. #1
    Join Date
    Jun 2005
    Posts
    7

    overcome j2se 1.3-1.4 incompatibility

    hi there,

    I had created on standalone samrt card application in jdk1.3,

    want to be compatible with 1.4

    Is there any impact on my application , what i will do to overcome this one

    any suugestion welcomed

  2. #2
    Join Date
    Aug 2003
    Posts
    313
    For the most part, java 1.3 should be compatible with 1.4; that is to say that, off the top of my head, I don't recall anything major that was changed. If you are having problems, you could check to see if anything in the library changed, but I would doubt it.

    If you start compiling on 1.4 and want to run it on 1.3 then you will need to use the -source and -target flags for the javac command. Check out the docs at:
    http://java.sun.com/j2se/1.4.2/docs/...ows/javac.html

    Hope this helps.
    ~evlich

  3. #3
    Join Date
    Jun 2005
    Posts
    7
    Quote Originally Posted by evlich
    For the most part, java 1.3 should be compatible with 1.4; that is to say that, off the top of my head, I don't recall anything major that was changed. If you are having problems, you could check to see if anything in the library changed, but I would doubt it.

    If you start compiling on 1.4 and want to run it on 1.3 then you will need to use the -source and -target flags for the javac command. Check out the docs at:
    http://java.sun.com/j2se/1.4.2/docs/...ows/javac.html

    Hope this helps.
    yes, it is true, whatever u said.. no problem cause?

    But my application r compiled in 1.3 and i try to run it in jre 1.4

    It is cause some error, i am not able to find out why the same application

    not running in different jre.

    Is there any thing in ur mind , pls reply, it will help me to overcome from this

    thnks for ur reply

  4. #4
    Join Date
    Jun 2005
    Posts
    7

    Cool compatiblity issues

    One major issue is char encoding support

    If ur app usin g shift_JIS encoding , then it create prob;lem when run in 1.4

    To overcome thi s add "charset.jar" file inside library

    hope this will help u

    irfan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center