DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 9 of 9

Thread: vbSendMail not working on install/working in dev environment

  1. #1
    Join Date
    Aug 2006
    Posts
    4

    vbSendMail not working on install/working in dev environment

    Anyone have this happen to them?

    vbSendMail works flawlessly when running the program from within VB6 but, the program using the dll, when installed doesn't complete the send?

    Status box gives me a "send succsesful" msg each time but, no email in the box.

    Any ideas?

  2. #2
    Join Date
    Dec 2005
    Location
    South of Nowhere, Maine
    Posts
    309
    Is it being blocked by a spam/anti-virus filter?

    I had this happen once with VB.Net - Symantec (Norton) anti-virus blocked the email on the senders side.

  3. #3
    Join Date
    Aug 2006
    Posts
    4
    Unfortunately no,

    All AntiVirus and Firewalls disabled...

  4. #4
    Join Date
    Dec 2005
    Location
    South of Nowhere, Maine
    Posts
    309
    Ok. Then check the next logical item. Is your email truly being sent, or is it giving you a "false positive" on the send?

    Is there a chance your code is giving you a "yup, it's sent" when it actually fails?

    If it is truly being sent, then you need to look into the receiving end. Is there something blocking it between the Send and Receive?

    Also... check the service that is being used to send the email. Some ISP's do not allow email to be sent from any system outside of their own. Some don't care. You might need to fiddle some settings somewhere.

  5. #5
    Join Date
    Aug 2006
    Posts
    4
    Hey edburdo thanks for the reply.

    I'm assuming I'm getting fals positive results as the mail is not making it to others' in boxes.

    All your suggestions are great but how could the dll send the mail perfectly each time in the development environment (VB6sp6) but when the program is compiled it fails for the same host. I have confirmation on different systems that no mail is getting through.

    Any suggestions???? mswinsock is installed and registered.

    Thanks everyone.

  6. #6
    Join Date
    Feb 2004
    Location
    Colton, CA
    Posts
    550
    Maybe you're missing another file (or some files) on the other client PCs.

    Try using FileMon from www.sysinternals.com to get a list of files being accessed (you can filter to show all files called by VB6)

  7. #7
    Join Date
    Mar 2007
    Posts
    3
    Quote Originally Posted by gatorstudios
    Hey edburdo thanks for the reply.

    I'm assuming I'm getting fals positive results as the mail is not making it to others' in boxes.

    All your suggestions are great but how could the dll send the mail perfectly each time in the development environment (VB6sp6) but when the program is compiled it fails for the same host. I have confirmation on different systems that no mail is getting through.

    Any suggestions???? mswinsock is installed and registered.

    Thanks everyone.
    Hello,

    I have exactly the same problem. have you found any solution ?
    Thanks,
    Eric.

  8. #8
    Join Date
    Aug 2006
    Posts
    4
    Hi Eric,

    Using the FileMon was the trick. An essential dll was not installed in the setup routine. I believe it is the MSWINSCK.OCX control (It's been a while since I've had to deal with vbSendMail, it just works...).

    Hope that helps.

  9. #9
    Join Date
    Mar 2007
    Posts
    3
    Hello,

    Thank you very much for your answer. Ii was not the problem, MSWINSCK.OCX was correctly registered...

    In fact, I included all the project "vbSendMail.vbp" in the main project (I got a .vbg project), then I ticked the compatibility component in the property project. After that the .exe works perfectly...

    Thanks again.

    Regards,
    Eric.

Similar Threads

  1. Replies: 0
    Last Post: 08-31-2005, 10:16 PM
  2. Replies: 1
    Last Post: 06-19-2002, 07:27 AM
  3. Making RDS work in dev environment
    By Joe in forum Enterprise
    Replies: 0
    Last Post: 08-24-2001, 07:02 PM
  4. VB in CT
    By ashley in forum VB Classic
    Replies: 0
    Last Post: 07-05-2000, 12:39 PM
  5. Hello
    By Clarise in forum Open Source
    Replies: 0
    Last Post: 07-05-2000, 12:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center