DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 2 of 2

Thread: Error 713 with DataReport

  1. #1
    Miroslav St. Jeliaskoff Guest

    Error 713 with DataReport


    Hi DB experts,
    I’m having a headache with DataReports and error 713.

    I was having a program running well on all PCs I installed it. It uses DataReport
    to show and print some reports from an MDB file. I’m using W2k Pro, VB6 SP5,
    MDAC 2.5 and VS Installer to create everything needed (the development PC).
    I have some CDs working great from this moment.
    Next I installed MDAC 2.6 and made some changes in the code, not concerning
    the report capabilities, because they wanted some more CDs and I build new
    installation packs, but now running the program it says “Error 713 – Application-defined
    or object defined error”. On my PC it works. I reinstalled everything on
    the development PC and only MDAC 2.5, changed the reference to that version
    of ADO. No change!

    I read the MSDN’s BUG on that issue but I have Microsoft Data Report Designer
    v6.0 (msdbrptr.dll) in the References of the project and it installs itself
    properly on the other machines I run my application on.
    And now my deadline is coming and any ideas will save me!

    Thanks,
    Miroslav St. Jeliaskoff


  2. #2
    Miroslav St. Jeliaskoff Guest

    Re: Error 713 with DataReport


    After 5 days of testing the problem was discovered:
    The updated Merge Modules have to be used instead of the ones that come with
    the VS Installer 1.1. We downloaded them from microsoft.com (mmenu.exe).
    The knowledge database of MS gives other way solve the problem but what they
    explain in their site (Q248055) does not work. Actually I think that the
    error 713 is not given only when the mentioned files are missing, but in
    our case too.

    So update your Merge Modules!

    Regards,
    Miroslav St. Jeliaskoff


    "Miroslav St. Jeliaskoff" <miroslav@earthling.net> wrote:
    >
    >Hi DB experts,
    >I’m having a headache with DataReports and error 713.
    >
    >I was having a program running well on all PCs I installed it. It uses DataReport
    >to show and print some reports from an MDB file. I’m using W2k Pro, VB6

    SP5,
    >MDAC 2.5 and VS Installer to create everything needed (the development PC).
    >I have some CDs working great from this moment.
    >Next I installed MDAC 2.6 and made some changes in the code, not concerning
    >the report capabilities, because they wanted some more CDs and I build new
    >installation packs, but now running the program it says “Error 713 – Application-defined
    >or object defined error”. On my PC it works. I reinstalled everything on
    >the development PC and only MDAC 2.5, changed the reference to that version
    >of ADO. No change!
    >
    >I read the MSDN’s BUG on that issue but I have Microsoft Data Report Designer
    >v6.0 (msdbrptr.dll) in the References of the project and it installs itself
    >properly on the other machines I run my application on.
    >And now my deadline is coming and any ideas will save me!
    >
    >Thanks,
    >Miroslav St. Jeliaskoff
    >



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center