DevX Home    Today's Headlines   Articles Archive   Tip Bank   Forums   

Results 1 to 3 of 3

Thread: ASP/WML

  1. #1
    Airpet Guest

    ASP/WML


    I am using Nokia WAP toolkit 1.2 and i am trying to write a simple program
    in wml & asp:

    <% @LANGUAGE="VBSCRIPT" %>
    <% Response.ContentType="text/vnd.wap.WML" %>
    <?xml version="1.0"?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
    "http://www.wapforum.org/DTD/wml_1.1.xml">

    <wml>
    <card id="card1">
    <p>
    the date is <%=date()%>
    </p>
    </card>
    </wml>

    But nothing happens.What am i doing wrong???????


  2. #2
    jayachandran Guest

    Re: ASP/WML


    Hi,
    What error message its giving? Also u no need to specify ><% @LANGUAGE="VBSCRIPT"
    %>.because u are not using any VBSCRIPT things.try the following code

    <wml>
    <% Response.ContentType="text/vnd.wap.wml" %>
    <?xml version='1.0'?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
    "http://www.wapforum.org/DTD/wml_1.1.xml">
    <wml>
    <card id="card1" title="Agent">
    <p>
    the date is <%=date()%>
    </p>
    </card>
    </wml>

    still u are facing any problem let me at jayachandran2k@yahoo.com

    "Airpet" <airpet@hotmail.com> wrote:
    >
    >I am using Nokia WAP toolkit 1.2 and i am trying to write a simple program
    >in wml & asp:
    >
    ><% @LANGUAGE="VBSCRIPT" %>
    ><% Response.ContentType="text/vnd.wap.WML" %>
    ><?xml version="1.0"?>
    ><!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
    >"http://www.wapforum.org/DTD/wml_1.1.xml">
    >
    ><wml>
    ><card id="card1">
    ><p>
    > the date is <%=date()%>
    ></p>
    ></card>
    ></wml>
    >
    >But nothing happens.What am i doing wrong???????
    >



  3. #3
    Gail Guest

    Re: ASP/WML


    You can try removing <% @Language="VBSCRIPT" %> OR bring the next statement
    up next to the language statement eliminating the whitespace in between.
    Some gateways won't process whitespace. You may also have to bring the xml
    and doctype statement up also, eliminating the whitespace.
    I don't even use the language statement in my apps and it works fine.

    "Airpet" <airpet@hotmail.com> wrote:
    >
    >I am using Nokia WAP toolkit 1.2 and i am trying to write a simple program
    >in wml & asp:
    >
    ><% @LANGUAGE="VBSCRIPT" %>
    ><% Response.ContentType="text/vnd.wap.WML" %>
    ><?xml version="1.0"?>
    ><!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
    >"http://www.wapforum.org/DTD/wml_1.1.xml">
    >
    ><wml>
    ><card id="card1">
    ><p>
    > the date is <%=date()%>
    ></p>
    ></card>
    ></wml>
    >
    >But nothing happens.What am i doing wrong???????
    >



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
HTML5 Development Center
 
 
FAQ
Latest Articles
Java
.NET
XML
Database
Enterprise
Questions? Contact us.
C++
Web Development
Wireless
Latest Tips
Open Source


   Development Centers

   -- Android Development Center
   -- Cloud Development Project Center
   -- HTML5 Development Center
   -- Windows Mobile Development Center